Web app loading issues

Incident Report for Rydoo

Resolved

This incident has been resolved
Posted May 07, 2026 - 12:38 CEST

Investigating

We're investigating reports of the web app getting stuck on loading. Our team is looking into it now. We'll share an update as soon as we know more.
Posted May 07, 2026 - 11:39 CEST
This incident affected: Expense.