Severe downgraded performance
Incident Report for Rydoo
Resolved
This incident has been resolved.
Posted Apr 27, 2021 - 12:13 CEST
Investigating
We are experiencing severe downgraded performance. Our development team is looking into this with the highest priority.
Posted Apr 27, 2021 - 11:22 CEST
This incident affected: Login/SSO, Expense, Mobile, API, Integrations, and Insights.