Issues with expense overview/details on Web

Incident Report for Rydoo

Resolved

The issue has been fully resolved. No workarounds needed.
Posted Jan 07, 2026 - 17:35 CET

Identified

Some users are currently experiencing issues loading the expense overview and details on the web app.
The mobile app works fine.

A temporary workaround if your expenses are not loading on the web app:
- Use an incognito/private window.
- Use the mobile app.
(This does not solve some projects/custom fields that might not be loading on the expense details in web.)

Our team is actively working on a full solution, and we will provide updates as soon as we have more information.
Posted Jan 07, 2026 - 13:55 CET
This incident affected: Expense.